Pre-Checks:
1) Update the adapter settings:
# chdev -l fscsi0 -a fc_err_recov=fast_fail
# chdev -l fscsi0 -a dyntrk=yes
2) Make sure that exported Lun exported from SAN should be available in both the VIOS which is going to be mapped to client lpar through vscsi.# chdev -l fscsi0 -a dyntrk=yes
3) Set reserve_lock to no for the disk which was added in both the vios from SAN.
Use the below commands to set it to no
#chdev -l hdisk1 -a reserve_lock=no
#chdev -l hdisk1 -a reserve_lock=no -P
4) Pre-check whether disk was by mistakenly used in any other client already
#chdev -l hdisk1 -a reserve_lock=no -P
#lqueryvg -Atp hdisk1
root@vio1:/ #lqueryvg -Atp hdisk1
0516-320 lqueryvg: Physical volume hdisk1 is not
asigned to a volume group.
0516-066 lqueryvg: Physical volume is not a volume group member.
Check the physical volume name specified.
root@vio1:/ #
root@vio1:/ #lqueryvg -Atp hdisk1
0516-320 lqueryvg: Physical volume hdisk1 is not
asigned to a volume group.
0516-066 lqueryvg: Physical volume is not a volume group member.
Check the physical volume name specified.
root@vio1:/ #
Implementation:
5) Map the disk to the client from both the vios check the diagram:
vioa:
#mkvdev -vdev hdisk1 -vadapter vhost1 -dev myvio1clivtd
viob:
#mkvdev -vdev hdisk2 -vadapter vhost1 -dev myvio2clivtd
#mkvdev -vdev hdisk1 -vadapter vhost1 -dev myvio1clivtd
viob:
#mkvdev -vdev hdisk2 -vadapter vhost1 -dev myvio2clivtd
Now in client:
6) Run config manager
#cfgmgr
root@cli1:/ #lspv
hdisk0 0004a256f06e0c6e rootvg active
hdisk1 0004a25613b2835f datavg
hdisk2 0004a25613b287f1 datavg
hdisk3 0004a2561dc9d8bd datavg
hdisk4 0004a2561dd57f15 datavg
hdisk5 0004a2561da57f16 None
root@cli1:/ #
7) Check the pathsroot@cli1:/ #lspv
hdisk0 0004a256f06e0c6e rootvg active
hdisk1 0004a25613b2835f datavg
hdisk2 0004a25613b287f1 datavg
hdisk3 0004a2561dc9d8bd datavg
hdisk4 0004a2561dd57f15 datavg
hdisk5 0004a2561da57f16 None
root@cli1:/ #
root@orange-lpar:/ #lspath -l hdisk5
Enabled hdisk5 vscsi1
Enabled hdisk5 vscsi2
8) Check the path prioritiesEnabled hdisk5 vscsi1
Enabled hdisk5 vscsi2
# lspath -AE -l hdisk5 -p vscsi1
priority 1 Priority True
# lspath -AE -l hdisk5 -p vscsi2
priority 1 Priority True
9) set path which was from viob to 2
priority 1 Priority True
# lspath -AE -l hdisk5 -p vscsi2
priority 1 Priority True
# chpath -l hdisk5 -a priority=1 -p vscsi1
# chpath -l hdisk5 -a priority=2 -p vscsi2
Its done now ...# chpath -l hdisk5 -a priority=2 -p vscsi2
any questions ask@unixmantra.com
0 blogger-disqus:
Post a Comment